Both zig and go use the dot operator, but I find the ‘::’ operator much more readable.

Vec::new();

Makes it clear that were accessing a static method belonging to the Vec struct/namespace.

Vec.new()

Makes it seem like Vec is an object with a ‘new’ method.

Am I alone in thinking this?

  • Pyro@lemmy.world
    cake
    link
    fedilink
    English
    arrow-up
    20
    ·
    6 months ago

    I used to only use C#, and I liked the simplicity of only using one symbol to access any prop/field/method. But now I’ve used Rust for a while I do prefer separating the two for the same reasons you mentioned.

    So no, you’re not alone. Even cross-lang!

  • ono@lemmy.ca
    link
    fedilink
    English
    arrow-up
    9
    arrow-down
    1
    ·
    6 months ago

    C++ was my language of choice for a long time, but I can’t say I’m with you on this one. If I’m going to use Vec, I had better know what it is already. Littering the code with a special double-glyph operator when a dot would do is just needless noise to me.

    (I won’t criticize you for liking it, though. Cheers.)

  • CrypticCoffee@lemmy.ml
    link
    fedilink
    arrow-up
    13
    arrow-down
    5
    ·
    6 months ago

    I don’t agree. Many languages differentiate in terms of standards. In Java, your objects start lowercase, so if you see uppercase, its a static call.

    :: looks nice, I guess, but many languages and standards improve clarity of code.

      • Ephera@lemmy.ml
        link
        fedilink
        arrow-up
        6
        ·
        6 months ago

        Yeah, but does that matter? I don’t think, I’ve ever accidentally broken these conventions, where compiler assistance would have been helpful.

      • CrypticCoffee@lemmy.ml
        link
        fedilink
        arrow-up
        3
        arrow-down
        9
        ·
        edit-2
        6 months ago

        It don’t get past review if it doesn’t follow standards. I’m yet to see a deviation.

        If a language is bad because devs do stupid things, they’re all bad.

    • huginn@feddit.it
      link
      fedilink
      arrow-up
      9
      arrow-down
      1
      ·
      6 months ago

      Also: :: in Java is method reference. In Kotlin it’s reflection.

      I’d say if you care a lot about distinguishing contexts it’s really the job of the IDE to highlight syntax.

      Don’t write code as though you’re going to read it in plain text imo.

    • Ephera@lemmy.ml
      link
      fedilink
      arrow-up
      3
      ·
      6 months ago

      Yeah, kind of curious what Go does here then / what the actual experience is like.
      It abuses casing for public/private, so presumably there’s no way to see whether a given sequence of letters is a variable or a type.

    • lysdexic@programming.dev
      link
      fedilink
      English
      arrow-up
      3
      arrow-down
      2
      ·
      edit-2
      6 months ago

      In Java, your objects start lowercase, so if you see uppercase, its a static call.

      Not really, that’s just the way a specific coding style was specified. You’re free to refactor all your projects to follow any other coding style if you really want to, and your programs will continue to work just fine.

  • BmeBenji@lemm.ee
    link
    fedilink
    arrow-up
    1
    ·
    6 months ago

    I don’t understand the C++ hate. I’m definitely biased since I learned it before anything else, but the flow of the code and the object-oriented principles just make sense to me. And yeah, I appreciate the scope resolution operator a lot.